Prerequisites

For the purposes of this lab, you will be using the AWS Management Console as well as Unity. You will need to have:

  • An AWS account with an IAM user that has the appropriate level of permissions to use the services needed for this lab (S3, Lambda, Kinesis, Glue, Athena, QuickSight, CloudWatch, API Gateway, Cognito). Create and activate a new AWS account if you do not have one already.

  • Unity 2020.1.0f1 or higher. While this may work with lower versions of Unity, it has not been validated. Download Unity and Unity Hub if you do not already have it installed.

  • Intermediate level knowledge of C# and Unity

This lab works for both Mac and Windows. If you already have these prerequisites, then you can continue on to the next portion of the lab. If not, continue on to create an IAM user.